Report bugs or give feedback for CrossCode.

Issues with Linux version

no avatar
User

TiZ

Posts

1

Joined

Mon Sep 24, 2018 5:43 am

Issues with Linux version

by TiZ » Mon Sep 24, 2018 5:47 am

Hi there. I posted this on the Steam forums too, but I think it's better served here.

Just got a few issues that I've noticed since the 1.0 release. I was an early adopter, and got about halfway through when the content ran out, so I decided I would take a rest and jump back in with 1.0 to get the full intended experience!

In the default branch, there is no vsync. I am able to fix this by using a compositor.
I am also able to fix this by switching to the new branch, however controllers do not work in the new branch at all! This is pretty critical and makes using it a non-starter for me.

I don't know if this happens in the new branch too, but sometimes the nice-looking linear scaling filter will turn off and it'll be ugly nearest filtering. Eventually the linear filter comes back. There doesn't appear to be a user-accessible setting for this.

I don't know if this is me being bad or something just not working, but the marked quest window doesn't appear for me even when I've got quests favorited.

I had a crash when I talked to Carla in her room, but the game didn't put any crash reports in the crash reports folder (which I understand to be $XDG_CONFIG_HOME/CrossCode/Crash Reports). I also had a crash in Autumn's Fall, but no report for that either.

Lastly, whenever I close the game or the game crashes, defunct processes will be left behind, and I'll have to do pkill -9 CrossCode to get rid of them. This prevents Steam from being able to close. Regular SIGTERM does nothing to them. They also leave behind the singletons in the config directory.

The game isn't making any useful output to stdout or stderr. However, I do record every game I play. Would videos of the game leading up to the crashes be useful?

Thanks for your time.
no avatar
User

carewolf

Posts

1

Joined

Thu Sep 27, 2018 9:54 pm

Re: Issues with Linux version

by carewolf » Thu Sep 27, 2018 9:58 pm

I have no issues with the graphics. I do see the processes on exit, and steam will think the game is still running until all the processes are killed. They look like Chromium helper processes, which often dont shut down correctly. Since the game doesnt need sandboxing, it could probably launch with --single-process Chromium mode and run that way.

I have however run into another problem on Linux. Using a controller seems to be bugger, half the controls work, but the right stick can only aim up and down, and the RT and BT buttons doesnt work, though the normal attacks on the bumbers do work just as well as the directional stick.

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron